Z Axis Binding?

This topic contains 2 replies, has 2 voices, and was last updated by  kerchen 5 years, 8 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #2402

    kerchen
    Participant

    Today I (finally) finished my machine and did a few test cuts (Yay!). It’s working pretty well with the EMC2 config that I downloaded from this site (with some changes to match my hardware). However, I’m having an intermittent problem with the Z axis. Sometimes it doesn’t move in response to a G00 command. For example, sending ‘G00 X [2] Y [2] Z [1]‘ moves as expected in x and y, but sometimes the Z doesn’t change even though there is enough room for it to move. Instead, the stepper makes a sound that is different from the normal sound and the sled doesn’t move. Might this indicate that the acme bolt is binding?

    With the two test cuts of the ‘EMC2 AXIS’ demo, the cut depth appears to be correct, so might this simply be a problem with using G00 to move the Z axis? In case it’s not obvious, I’m a complete noob at G-code and CNC machines. :)

    Any advice or insights are very welcomed!

    Thanks,

    Paul

    #3836

    Taylor
    Keymaster

    @kerchen,

    I seem to remember we had a similar issue initially, but I’ll have to hit the archives to confirm. I think it relates to the fact that Z is mechanically different from X/Y. For starters, Z has a much higher resolution than the other two axes. First, try detaching the ACME rod and sliding the cart up and down. If it moves relatively freely, binding is not the issue. Next, try adjusting your micro-stepping settings, both in EMC and through the jumpers on the board. Finally, you may just be moving Z too fast, so I’d fiddle with that too.

    Hope that helps! I’ll post if I find a definitive solution on my end.

    #3837

    kerchen
    Participant

    Currently I’m using 1/4 micro-stepping for Z. The problem only seems to happen when I move the sled fast by a large amount (1+ inches); I haven’t had any problems with small/slow movements, so I guess I can live with this. ;)

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.